W3C home > Mailing lists > Public > public-audio@w3.org > July to September 2012

[Bug 18442] New: noteOn() and noteOff() methods should be renamed

From: <bugzilla@jessica.w3.org>
Date: Tue, 31 Jul 2012 00:21:32 +0000
To: public-audio@w3.org
Message-ID: <bug-18442-5429@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=18442

           Summary: noteOn() and noteOff() methods should be renamed
           Product: AudioWG
           Version: unspecified
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Web Audio API
        AssignedTo: crogers@google.com
        ReportedBy: joe@noteflight.com
         QAContact: public-audio@w3.org


The noteOn() and noteOff() methods of AudioBufferSourceNode are confusingly
named in two respects.  

1. The noteOff() method's name suggests a strong similarity to the MIDI concept
of "Note Off", but the two ideas differ in a way that is likely to be
confusing. The MIDI terminology is already well established and familiar to
musicians. A MIDI "Note Off" event typically triggers the start of the release
phase of a virtual instrument's note, which can last for an arbitrary amount of
time before audio output actually ceases (since most musical instruments do not
immediately stop producing sound when the performer stops playing).  On the
other hand, the noteOff() method causes audio to completely cease at the
specified time.

2. The node may serve as a source for many kinds of audio other than musical
notes, so the terminology is needlessly narrow.

Chris Rogers has suggested that start() and stop() may be clearer alternatives.

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Tuesday, 31 July 2012 00:21:34 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 31 July 2012 00:21:34 GMT