Re: ISSUE: owl:Class name misleading; try owl:Set?

From: Dan Connolly <>
Subject: ISSUE: owl:Class name misleading; try owl:Set?
Date: 01 Jan 2003 14:25:21 -0600

> Based on some comments about sameClassAs
> and chatting with a few people about the relationship
> between rdfs:Class and owl:Class, I have come to
> the conclusion that owl:Set would be a better name
> for what we currently call owl:Class.

OWL classes do not act like sets.  They have an identity distinct from
being a set of their instances.

> In RDFS, one can have two classes whose
> members are {a,b,c}, but they can be distinct;
> the one class might be rdfs:label'ed "first
> three letters" and the other might e rdfs:label'ed
> "my three favorite letters". RDFS classes have
> properties other than their extension.
> In DAML+OIL, if they have the same members, they're
> the same class.

Incorrect.  Two distinct classes in DAML+OIL can have the same members.
Two distinct classes in DAML+OIL can even necessarily have the same

> Gee, to me, that sounds like a set.

If it was correct, then DAML+OIL classes would be more like sets.

> In fact, I asked for terms for sets as soon as
> I realized how rdfs:Class works:
> vocabulary for traditional sets
> From: Dan Connolly (
> Date: Tue, Nov 06 2001
> We already use set-theoretic terms like
> intersectionOf, unionOf...
> so I think owl:Set is a better name for what
> we call owl:Class. And owl:sameMembersAs
> is probably better than owl:sameClassAs.

OWL classes are not sets, so owl:Set is not a good name for them.

owl:sameMember[s]As might be a better name for owl:sameClassAs.

> These should be theorems in full owl:
> 	?X owl:sameMembersAs ?Y
> 	<==>
> 	?X rdfs:subClassOf ?Y.
> 	?Y rdfs:subClassOf ?X.

This is now true for owl:sameClassAs

> and
> 	?X rdf:type owl:Set.
> 	?Y rdf:type owl:Set.
> 	?X owl:sameMembersAs ?Y.
> 	==>
> 	?X owl:sameAs ?Y.

This is not true in OWL.

> (we did rename equivalentTo to sameAs, didn't we?
> I should look that up...)
> I suppose this is a new issue; I don't think I could
> argue that it's an editorial fix. Sorry I didn't
> get it in sooner.

I'm not sure what you are proposing here.  It seems to me that you are
either saying that OWL classes already act like sets, which is incorrect,
and thus that various names should be changed, or that OWL classes should
act like sets, which I would oppose.

> Dan Connolly, W3C


Received on Wednesday, 1 January 2003 17:00:09 UTC