W3C home > Mailing lists > Public > www-style@w3.org > September 2016

Re: [motion-1] !important: motion-* rename

From: Amelia Bellamy-Royds <amelia.bellamy.royds@gmail.com>
Date: Fri, 30 Sep 2016 11:07:07 -0400
Message-ID: <CAFDDJ7wQ091wtUzuZujbONe3CspW7iOVRB8ZFfw4WAKVPpwAwA@mail.gmail.com>
To: Alan Stearns <stearns@adobe.com>
Cc: Jonathan Kew <jfkthame@gmail.com>, "www-style@w3.org" <www-style@w3.org>
On 30 September 2016 at 10:09, Alan Stearns <stearns@adobe.com> wrote:

> But what if we reversed the terms?


> path-transform (shorthand)
> path-transform-shape (= motion-path / offset-path)
> path-transform-anchor (=offset-anchor)
> path-transform-offset (= offset-position)
> path-transform-distance (= offset-distance)
> path-transform-rotation (=motion-rotation / offset-rotation)
>
> This was going to be my second choice suggestion, so I'd be happy with it.
Saves a few characters, anyway.  We had for a while discussed using a
`path` property for SVG path data, but ended up sticking with `d` in the
spec, so I think the path-* prefix is safe.

~ABR
Received on Friday, 30 September 2016 15:07:43 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:09:04 UTC