Re: [css-animations][web-animations] steps() timing function sometimes unintuitive

nexii, in the WAAPI Slack, suggested frames(). I liked it when I heard it,
and after thinking about it overnight, I like it even more.

frames(N) translates directly - it means "split this animation into N
frames".  The "frame" terminology is common enough that the metaphor should
be readily understood.  The spelling is simple.  It automatically suggests
that both the starting and ending values show up (they have to be in one of
the "frames", after all).  It's a noun that is easy to talk about

(Obviously N must be 2 or greater. frames(1) would be invalid, same as
steps(0). We *could* give frames(1) a meaning, but we'd have to decide
whether it has step-start or step-end behavior, and that's better done by
the step-start/end keywords already.)

So I think I'm throwing all of my votes behind frames() as the name for
this, and then we can mostly forget about steps().


Received on Friday, 11 March 2016 18:55:16 UTC