Re: [css-pseudo] Need a way to styling the disclosure triangle of the <details> (or <summary>) element

On 08/03/2016 17:20, Tab Atkins Jr. wrote:

> People do not think "oh, this navbar is basically a table, I should
> use display:table for it, that seems appropriate".  They think "I need
> these to be horizontal. display:table does that, I guess I'll use it".
> It's a functional understanding of the values - they have some effect,
> I need that effect, I'll use them.  It's just a tool in their toolbox,
> sitting right next to "lots of floats" and "display:inline-block".

And I've been here discussing the matter every single time
what we were standardizing was, IMO, prone to abuse or confusion.

> There hasn't been a lot of call for "a block with a marker" yet, so I
> wouldn't be surprised if most people haven't built up a functional
> understanding of what display:list-item does; it's pretty reasonable
> for them currently to think of it as "the thing that goes on <li>".
> But there's no reason to presume that it will stay this way, and
> people will have trouble adapting their functional understanding of
> the value.

What *is* (I can bolden things too) reasonable is to always do what
we have to do the best possible way because when we don't, we OFTEN
IF NOT ALWAYS end up years later with a MUCH larger problem. I am
reacting here because I have more than the gut feeling we're reusing
something in a suboptimal manner. Patrick expressed it better than I
could do.

> (All this presumes that people *will care in the slightest*, which I
> doubt for the most part.  We're adjusting the UA stylesheet for a
> rarely-used element, not authoring a new tutorial guide.)

In short, "people don't care, this is minor, our hack is enough".
This is not really how I see standards' production, and this is not
how I care about our users, web authors.

Reality is that we should alias the 'list-item' value to 'marked',
have "marker-*" property aliases for 'list-*' properties, and move to
those new values to do things the clean way. We made a bit of a MISTAKE
when we designed the older names, sticking to lists instead of going to
the essential (markers) so it could be reused in the future without
FWIW, Gecko already has aliases machinery for webkit-prefixed stuff


Received on Tuesday, 8 March 2016 17:04:37 UTC