Re: [css-ruby] Propose to use a different syntax for inter-character annotation

On 09/03/2015 09:48, Xidorn Quan wrote:
> I propose to remove inter-character keyword from ruby-position, and
> handle annotation as inter-base annotation if the writing-mode of the
> text container is orthogonal to that of the base container or ruby
> container.
> The reasons are:
> 1. We have met some style computation problems for the keyword
> inter-character, like the cyclic dependency between writing-mode and
> display. And solving those problems seem to be non-trivial.
> 2. The behavior of an orthogonal text container is never defeined.
> 3. The keyword inter-character could be confusing, because what it does
> is not essentially inter-character. It is inter-base for horizontal
> line, and not inter- anything at all for vertical line.
> For these reasons, I propose this change.
> The only concern for this proposal is that, it will make authors have to
> add <rtc> for inter-character annotation, instead of just specifying the
> proper ruby-position on some ancestor. But I guess it could be solved if
> we backport the writing-mode of an anonymous text container from its
> first child. Backporting a property to an anonymous box might probably
> be less tricky.

I may be missing the point somewhere, but these are my first reactions, 
coming at this from a user perspective, rather than an immplementation 

I think we need to keep things as simple as possible for the content 
author – there are already quite a few complications for them to handle 
when dealing with writing modes, and bopomofo already requires a fair 
amount of markup.

I always expected use of the 'inter-character' property to be *the thing 
that triggers* vertical alignment of the ruby text (per the spec), and 
that we would thereby spare the content author the trouble of adding an 
extra rule for writing mode, especially given that all 'inter-character' 
bopomofo is vertical anyway.

Since this orientation is really only practically used for bopomofo 
ruby, i originally suggested that the property actually be called 
'bopomofo'. Subsequent spec editors tried to make it sound a little more 
generic with 'inter-character', but, i'm not sure that there are any 
real use cases other than the bopmofo one (which is also what the spec 
implies, per my reading).

I'd be really disappointed if authors had to add more markup, such as 
<rtc>, to make bopomofo work. Given that bopomofo *is* normally used 
after every character, rather than groups of characters, it would really 
mess up what was intended to be simple and easy to read/write semantic 


Received on Wednesday, 11 March 2015 18:32:08 UTC