Re: [css-writing-modes] Rename extent/measure to block-size/inline-size?

"Tab Atkins Jr." <> wrote on 2014/03/05 4:07:14
> On Mon, Mar 3, 2014 at 11:14 PM, fantasai <> wrote:
> > On 02/28/2014 02:58 AM, Simon Sapin wrote:
> >> I know it’s not Last Call yet :) But what do you think of renaming
> >> "extent" a.k.a. "logical height" to "block size", and
> >> "measure" a.k.a. "logical width" to "inline size"?
> We consistently use "size" as a neutral term for width/height, so I'm
> happy to continue using that.
> I did a quick grep through the repo to find sentences that use
> measure/extent currently, and replacing those instances with
> inline-size/block-size feels pretty natural.  I'm happy with this.

I'm happy with this, too.
Also I think "block-size" is better than "block size" because the
two words "block size" sounds like "block's size" (2-dimensional).

BTW, the current draft says about the physical dimensions:
  "The physical dimensions are width and height, which correspond to 
  measurements along the x-axis (vertical dimension) and 
  y-axis (horizontal dimension), respectively."
Is this correct? (I think x-axis is horizontal dimension)

Shinyu Murakami
Antenna House

Received on Thursday, 6 March 2014 02:25:27 UTC