Re: [css-writing-modes] Rename extent/measure to block-size/inline-size?

On Mon, Mar 3, 2014 at 11:14 PM, fantasai <> wrote:
> On 02/28/2014 02:58 AM, Simon Sapin wrote:
>> Hi,
>> I know it’s not Last Call yet :) But what do you think of renaming
>> "extent" a.k.a. "logical height" to "block size", and
>> "measure" a.k.a. "logical width" to "inline size"?
>> I may be getting English wrong, but to me "extent" and "measure" are both
>> synonymous to "size". The terms by themselves don’t
>> tell me which is which. I understand (after reading it in the spec) that
>> "measure" is more specific in typography, but I don’t
>> know how much of the "target audience" is familiar with that. I wasn’t.
>> Logical height and logical width, on the other hand, are
>> horizontal-centric and kinda backwards when used for vertical text.
>> Gecko uses "block size" and "inline size" internally, which fits nicely in
>> the pattern of the existing
>> block-start/block-end/inline-start/inline-end terms.
>> As far as I know, these terms do not appear in CSS syntax, so this change
>> would not affect implementations and would be only
>> editorial. It’s still a big change, though; several other specs are using
>> these terms.
> I'm okay with this. It's consistent with inline/block-start/end, even.
> And since, as you note, it's completely editorial, we could even do
> it as a post-CR update to CR, so it won't hold up the CR transition. :P
> Would like to hear from other WG members, though, what they think.
> (I'm sure they prefer something to measure/extent, just unsure what,
> exactly. Maybe someone has a preferred synonym of size.)

We consistently use "size" as a neutral term for width/height, so I'm
happy to continue using that.

I did a quick grep through the repo to find sentences that use
measure/extent currently, and replacing those instances with
inline-size/block-size feels pretty natural.  I'm happy with this.


Received on Tuesday, 4 March 2014 19:08:01 UTC