[css-masking] lc issue 2: rename mask-* properties

Hi fantasai,

LC Issue 2 [1] is still open and I would very much like to resolve it now. We discussed renaming all current long hand properties for mask-* a while back and it seems there is no one in favor for renaming mask-image, mask-type, mask-size and others. The structure of the spec got much cleaner and I do not believe that people would still get confused by reading the spec. Can we close this issue?


[1] http://dev.w3.org/fxtf/masking/issues-lc-2013.html#issue-2

On Dec 17, 2013, at 2:35 PM, Dirk Schulze <dschulze@adobe.com> wrote:

> On Dec 11, 2013, at 4:24 PM, Dirk Schulze <dschulze@adobe.com> wrote:
>> Hello fantasai,
>> Thank you very much for taking the time to review CSS Masking again. I am splitting your comments into different topics. This way we can discuss them in different threads.
>> On Dec 11, 2013, at 11:46 AM, fantasai <fantasai.lists@inkedblade.net> wrote:
>>> [Sorry for the late response. I haven't felt like working lately.]
>>> Non-editorial:
>>> 1. I'm wondering if the naming of the properties should follow the pattern
>>>      mask-x shorthand with mask-x-* longhands for layered masks;
>>>      mask-y shorthand with mask-y-* longhands for box-image masks;
>>>      mask-type not prefixed by x or y since it's not part of either set;
>>>      x and y as, preferably, a single word
>>>    since this would best reflect the relationships among the properties.
>>> 2. Would like to see 'mask-box-image' shortened to 'mask-box' (or some
>>>    other short alternative) as was mentioned in this thread:
>>>      http://lists.w3.org/Archives/Public/www-style/2013Jun/0599.html
>>>      http://lists.w3.org/Archives/Public/www-style/2013Jun/0634.html
>>>    because it's imho unnecessarily long.
>> You are right. We discussed this before. My proposal to your request back then was an infrastructure like this [1]:
>> mask
>> +-- mask-layer
>> |    +--mask-layer-image
>> |    +--mask-layer-position
>> |    +--mask-layer-repeat
>> |    etc.
> In case we decide to rename the positioned masking properties. fantasai, you suggested renaming the heading “Layered Masking” to “Positioned Masking”. I assume you would like to have a different naming schema for the properties as well. ‘mask-position-*’ might be confusing in combination with the '*-position’ longhand. Do you maybe have another suggestion?
>> +-- mask-box
>>    +--mask-box-source
>>    +--mask-box-slice
>>    +--mask-box-repeat
>>    etc.
> I changed ‘mask-box-image-‘ to ‘mask-box-*’. We can discuss this change during the call tomorrow.
> Greetings,
> Dirk

Received on Saturday, 12 April 2014 08:46:09 UTC