W3C home > Mailing lists > Public > www-style@w3.org > January 2010

Re: Proposal: parent selectors

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Fri, 22 Jan 2010 07:55:56 -0600
Message-ID: <dd0fbad1001220555s54fdb18bu87437b85cf1d2e49@mail.gmail.com>
To: Eduard Pascual <herenvardo@gmail.com>
Cc: Boris Zbarsky <bzbarsky@mit.edu>, www-style@w3.org
On Thu, Jan 21, 2010 at 7:05 PM, Eduard Pascual <herenvardo@gmail.com> wrote:
> However, I don't think we need to bloat the syntax with different
> names for each version: simply use the generic name, like :has() or
> :matches(), now for the limited version, requiring the argument to
> begin with ">" (or maybe allowing also "+"), and when implementations
> of the full version become a reality the spec can just lift the
> restriction.

The problem with that is that it's too easy for an author to
accidentally slip into the bad-performance version just because they
forgot to put the ">" at the beginning.  Even if we figure out an
acceptable way to handle the general case, the child case will still
be much more efficient, so it's a good thing to make it easier to use

Received on Friday, 22 January 2010 13:56:46 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:07:42 UTC