W3C home > Mailing lists > Public > www-style@w3.org > April 2010

Re: [css3-animations] Property Naming Proposals

From: Simon Fraser <smfr@me.com>
Date: Mon, 05 Apr 2010 15:45:02 -0700
Cc: "www-style@w3.org" <www-style@w3.org>
Message-id: <303C6AF5-F11F-4E7F-91DC-997E73345236@me.com>
To: fantasai <fantasai.lists@inkedblade.net>
On Apr 5, 2010, at 3:30 PM, fantasai wrote:

> There were a a couple proposals at the F2F that I wanted to make
> sure didn't get lost.
> From Bert:
>  Rename animation-iteration-count to animation-play-count
>    * easier to spell
>    * consistent with marquee-play-count

OK with me.

> From Tantek:
>  Rename animation-duration to animation-period
>    * Avoids confusion about whether it refers to the duration
>      of a cycle, or the total length of the animation. (This
>      kind of mix-up came up several times during the discussion.)

Period is a bit geeky, but more precise. I could go either way.

> Bert also mentioned thinking about the difference between
> animation-direction and marquee-direction.

Here's marquee-direction:


I have no opinion at present.

> I'll tack on a fly-by suggestion from me (could be totally off):
>  Rename animation-fill-mode to animation-extend: start | end | both
>    * We have enough "fill" concepts already
>    * Avoids semantically-empty "mode" component

Note that we have a fairly strong desire to keep "fill-mode" to match SMIL:

but if you consider "mode" to be redundant it could be "animation-fill":

Note that the original proposal was:

  animation-fill-mode:  none | forwards | backwards | both;

and those values could also be used with "animation-extend".

Received on Monday, 5 April 2010 22:45:51 UTC

This archive was generated by hypermail 2.4.0 : Monday, 23 January 2023 02:13:44 UTC