W3C home > Mailing lists > Public > www-style@w3.org > April 2010

[css3-animations] Property Naming Proposals

From: fantasai <fantasai.lists@inkedblade.net>
Date: Mon, 05 Apr 2010 15:30:12 -0700
Message-ID: <4BBA6474.1040408@inkedblade.net>
To: "www-style@w3.org" <www-style@w3.org>
There were a a couple proposals at the F2F that I wanted to make
sure didn't get lost.

 From Bert:
   Rename animation-iteration-count to animation-play-count
     * easier to spell
     * consistent with marquee-play-count

 From Tantek:
   Rename animation-duration to animation-period
     * Avoids confusion about whether it refers to the duration
       of a cycle, or the total length of the animation. (This
       kind of mix-up came up several times during the discussion.)

Bert also mentioned thinking about the difference between
animation-direction and marquee-direction.

I'll tack on a fly-by suggestion from me (could be totally off):
   Rename animation-fill-mode to animation-extend: start | end | both
     * We have enough "fill" concepts already
     * Avoids semantically-empty "mode" component

Received on Monday, 5 April 2010 22:31:03 UTC

This archive was generated by hypermail 2.4.0 : Monday, 23 January 2023 02:13:44 UTC