Re: ARIA Proposal

On Thu, 27 Sep 2007 05:38:17 +0200, Matthew Raymond  
<> wrote:
>    With regard to the |role| attribute, I suggest you replace it with an
> attribute named "aria-role" for the following reasons:
> 1) It maintains consistency with your aria-/attribute/ nomenclature.
> 2) You don't have to modify the parsing of the |role| attribute to treat
> ARIA elements as if they were in the XHTML namespace. Instead, you have
> a separate attribute that only takes the roles defined in the WAI-ARIA
> Roles spec.

I'm not sure how this is an advantage though. If you would go down this  
path you would have to define interaction between


which seems worse than just defining the interaction between role= and  
html:role=. Actually, if you also introduce html:aria-role for other  
languages than HTML to make it all consistent it becomes even more  
complicated. I agree that it would've been nice if all attributes used the  
aria- prefix, but we already have some deployed content here plus it seems  
to me that giving up role= is not that big of a deal.

Anne van Kesteren

Received on Thursday, 27 September 2007 13:13:48 UTC