Re: ARIA Proposal


Integrating all of ARIA into generic HTML 5 elements is not practical 
right now. Please check the FAQ and see if that helps you understand why:

As for "aria-role" instead of "role", we'll reply to Matthew's email.

- Aaron

Aaron Leventhal
IBM web accessibility architect
Mozilla accessiblity lead

Joshue O Connor <> 
Sent by:
09/27/2007 08:25 AM
Please respond to

Matthew Raymond <>
cc, public-html <>, Simon Pieters 
Re: ARIA Proposal

I don't wish to speak out of turn here as there are many on this list
who know more about this stuff than I do but it seems to me that using
something that specifically says "This is an ARIA attribute" may be
easier to author as it's origin/purpose etc is explicit by the use of
the ARIA prefix. So from that perspective what Mathew suggests;

| <div aria-role="checkbox" aria-checked="true"></div>

looks like a good idea. Or should the ARIA states/properties be authored
as more generic type elements that are hardwired into the spec rather
like the way heading and list elements or proposed elements a la
<figure> currently are?


Received on Thursday, 27 September 2007 13:05:01 UTC