Re: ARIA Proposal

   With regard to the |role| attribute, I suggest you replace it with an
attribute named "aria-role" for the following reasons:

1) It maintains consistency with your aria-/attribute/ nomenclature.

2) You don't have to modify the parsing of the |role| attribute to treat
ARIA elements as if they were in the XHTML namespace. Instead, you have
a separate attribute that only takes the roles defined in the WAI-ARIA
Roles spec.

3) People who use |role| aren't confused by the lack of a namespace for
ARIA roles and have a clear understanding that the roles are ARIA-related.

4) Even with ARIA roles placed directly in the XHTML namespace, the only
other unnamespaced roles the the |role| attribute can take are the nine
defined in the XML Role Attribute spec, and many of those conflict with
proposed elements in HTML5. Thus, to justify the existence of the |role|
attribute in HTML, you need ARIA. The opposite, however, is not the case.

   Here's an example of how the new attribute would be used:

| <div aria-role="checkbox" aria-checked="true"></div>

   Also, I suggest we allow the new |aria-role| attribute to take only a
single ARIA role as a value. The WAI-ARIA Role spec doesn't really
define how to deal with the use of multiple ARIA roles simultaneously,
nor does it give an example of such. Having a single value makes it
easier to parse, easier for authors to read and write, and takes up less
space in the HTML5 specification.

Received on Thursday, 27 September 2007 03:39:51 UTC