NEW ISSUE 4251 - Change syntax of some WSDL 1.1 identifiers

This issue was first discussed in my note
It recommended that the syntax of the identifiers
- wsdl11.portTypeMessageReference(portType/operation/message)
- wsdl11.portTypeOperationFault(portType/operation/fault)
be changed to 
- wsdl11.portTypeMessageInput(portType/operation)
- wsdl11.portTypeMessageOutput(portType/operation)
- wsdl11.portTypeMessageFault(portType/operation)

Similar changes were recommended for the corresponding identifiers for the
binding element.

David Orchard argued that the syntax was designed to align with the WSDL 2.0
syntax.  So, I asked the WSDL 2.0 WG for their opinion.  They explained their
rationale in

Jonathan Marsh expressed their opinion succinctly as "The WG expressed no
preference on whether your suggested redesign was a
benefit for WSDL 1.1 component designators, where there isn't support for
MEP extensibility.  We note that if consistency with WSDL 2.0 component
designators is paramount, keeping this redundant information in the format
would be desirable.  Yet if simplicity is paramount, removing the redundant
information as you suggest would be natural."

Thus, we need to answer Jonathan's question above and take the appropriate

All the best, Ashok

Received on Wednesday, 17 January 2007 18:55:35 UTC