W3C home > Mailing lists > Public > public-webrtc@w3.org > May 2014

[Bug 25596] New: updateIce should be called setConfiguration

From: <bugzilla@jessica.w3.org>
Date: Thu, 08 May 2014 06:00:44 +0000
To: public-webrtc@w3.org
Message-ID: <bug-25596-4991@http.www.w3.org/Bugs/Public/>

            Bug ID: 25596
           Summary: updateIce should be called setConfiguration
           Product: WebRTC Working Group
           Version: unspecified
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: WebRTC API
          Assignee: public-webrtc@w3.org
          Reporter: harald@alvestrand.no
                CC: public-webrtc@w3.org

After discussion on the list (May 2014), it seems agreed that:

- updateIce is a bad name for the function, since it updates more than ICE
- it makes sense to just give a single call that updates the configuration
given to the RTCPeerCOnnection constructor
- setConfiguration() is a good name for this function
- we also need getConfiguration() to provide the ability to modify a
configuration parameter

This seems ready for editing.

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.
Received on Thursday, 8 May 2014 06:00:46 UTC

This archive was generated by hypermail 2.3.1 : Monday, 23 October 2017 15:19:40 UTC