W3C home > Mailing lists > Public > public-webrtc@w3.org > October 2012

Forgot to prefix some names....

From: Harald Alvestrand <harald@alvestrand.no>
Date: Thu, 04 Oct 2012 13:29:06 +0200
Message-ID: <506D7302.60807@alvestrand.no>
To: "public-webrtc@w3.org" <public-webrtc@w3.org>

I think we decided some time ago that in order to limit our impact on 
the namespace, we'd prefix our interfaces and data types with "RTC".

It seems that we've mostly done this, but not fully; the following 
interfaces are not prefixed:

- DataChannel interface
- MediaStreamEvent
- DataChannelEvent
- DataChannelState enum
- DataChannelInit dictionary
- DataChannelEventInit dictionary
- MediaStreamEventInit dictionary

I may have missed some.
For the MediaStream stuff, we can argue that this is from another spec 
that we're not changing (using the MediaStream prefix), but the 
DataChannel is purely a WebRTC construct.

Is there any objection to just adding the prefix?

Received on Thursday, 4 October 2012 11:29:35 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:17:34 UTC