[Bug 26904] New: Introduce typedef for IDBKeyPath, use it

https://www.w3.org/Bugs/Public/show_bug.cgi?id=26904

            Bug ID: 26904
           Summary: Introduce typedef for IDBKeyPath, use it
           Product: WebAppsWG
           Version: unspecified
          Hardware: PC
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Indexed Database API
          Assignee: dave.null@w3.org
          Reporter: jsbell@google.com
        QA Contact: public-webapps-bugzilla@w3.org
                CC: mike@w3.org, public-webapps@w3.org

The IDB spec could be simplified by adding:

typedef (DOMString or sequence<DOMString>) IDBKeyPath;

And then using it in a handful of places:

interface IDBObjectStore {
  readonly attribute IDBKeyPath? keyPath; // replacing 'any'
  IDBIndex createIndex (DOMString name, IDBKeyPath keyPath, optional
IDBIndexParameters optionalParameters); // replacing explicit union
}

dictionary IDBObjectStoreParameters {
    IDBKeyPath? keyPath = null; // replacing explicit union
};

interface IDBIndex {
    readonly attribute IDBKeyPath keyPath; // replacing 'any'
}

This would not change the defined behavior at all.

-- 
You are receiving this mail because:
You are on the CC list for the bug.

Received on Thursday, 25 September 2014 17:07:15 UTC