public-webapps-bugzilla@w3.org from January 2014 by subject

[Bug 14949] [Meta]: Component Model needs an Explainer document

[Bug 14968] [Meta]: Specify how custom elements work

[Bug 14978] [Meta]: Specify how shadow DOM works

[Bug 15157] [Explainer]: Add an example testing an element for the right prototype

[Bug 15279] Update WebSockets tests to remove support for MozWebSocket

[Bug 15817] [Shadow]: Look at Windows 8 controls as shadow DOM use cases

[Bug 17648] [Awaiting ES6] Add iterators

[Bug 19672] [Shadow]: The use of the word "variables" is somewhat confusing.

[Bug 19878] Revert change in Close-reason-unpaired-surrogates.htm ?

[Bug 20017] [Shadow]: Retargeting relatedTarget algorithm prevents events from be fired if a user creates a MouseEvent manually with a relatedTarget which is same to the target.

[Bug 20139] [Shadow]: Scoping constraints should be informative

[Bug 20141] [Shadow]: Ensure that distribution/composition is triggered in all the right places

[Bug 20458] 4.2.22: converting IDL value to IDL type?

[Bug 20567] Change [[Prototype]] for concept-node-adopt?

[Bug 20683] [Imports]: Write HTML Imports spec

[Bug 20957] [Shadow]: Styling elements in shadow trees based on host element

[Bug 20976] Define Node.baseURI properly

[Bug 21422] Generic Promise type notation

[Bug 21696] add onbefore(copy|cut|paste) tests

[Bug 21697] spec onbefore(cut|copy|paste) in more detail

[Bug 21699] [spec.next] figure out how to make clipboard data type support discoverable

[Bug 21740] Guidance on DOMError and promises

[Bug 21916] bug-assist should use data-* attributes instead of <meta name>

[Bug 22059] Composition dictionary should be changed

[Bug 22108] [Shadow]: Some editorial issues

[Bug 22238] [Shadow]: "part" should be a reflected attribute

[Bug 22239] [Shadow]: An exception to applyAuthorStyles should be carved out for custom pseudos

[Bug 22320] Form's supported property names should perhaps not be enumerable

[Bug 22358] Add a "this is the global" annotation

[Bug 22462] [Shadow]: Consider adding an applyAuthorHostStyles flag

[Bug 22507] Need to define behaviour for setting properties on named properties objects

[Bug 22522] WebIDL, error handling, and promises

[Bug 22600] Need a way to make navigator.plugins supported named properties not enumerable

[Bug 22646] So if we want to say on a per-object basis whether it ought to be exposed to workers (which I think is useful) lets introduce "exposed to document environments", "exposed to worker environments", and [...]

[Bug 22691] Remove ByteString from WebIDL

[Bug 22715] [Shadow]: [Meta] New features and improvements

[Bug 22716] [Shadow]: [Meta] Cleanup, refactoring, and polish

[Bug 22745] [Explainer]: Use case for registering a type extension of an unknown element

[Bug 22788] [Shadow]: Clarify apply-author-styles when styling elements in shadow trees based on host element

[Bug 22836] Missing First Principle in overall Design

[Bug 22858] use @@hasInstance instead of [[HasInstance]]

[Bug 22874] #es-stringifier algorithm shouldn't use ToString(V)

[Bug 22898] [Shadow]: Consider defining inertness in terms of the composed tree

[Bug 22912] fix [[Delete]] due to how it's changed in ES6

[Bug 23045] [Shadow]: ::part should override styles declared in a shadow tree

[Bug 23056] Function's length property is inconsistent with EcmaScript

[Bug 23062] [Shadow]: [Meta] Style related issues

[Bug 23070] [Explainer]: Remove custom element declarative syntax from the explainer.

[Bug 23071] [Explainer]: Update explainer to use :host and ::content

[Bug 23087] Undefined variable use in the overload resolution algorithm

[Bug 23147] Describe File API Model

[Bug 23162] [Shadow]: ::part should be targetable through n-levels of ShadowDOM

[Bug 23232] clipboardData.clearData() should not clear clipboard

[Bug 23235] allow triggering copy action from certain event handlers

[Bug 23266] ExtendedAttributeTypePair grammar appears wrong

[Bug 23277] Broken references to EcmaScript spec

[Bug 23393] [Explainer]: Update or remove "Custom Elements" section to match current Custom Elements spec

[Bug 23487] Actually define going fullscreen

[Bug 23536] figure out if "mixed clipboard content" is testable, write tests if it is

[Bug 23547] make sure the spec is clear enough about clearing clipboard before writing new content to it

[Bug 23606] [imports]: Returning null when "the resource is CORS-cross-origin" seems wrnog

[Bug 23625] [Shadow]: Consider removing apply-author-styles flag

[Bug 23636] [Shadow]: selectors in style elements in shadowRoots should match in sibling shadowRoots

[Bug 23682] Fix the current [ArrayClass], [] and sequence<T> mess

[Bug 23701] Remove TreatUndefinedAs

[Bug 23719] Consider adding pull style flow control method to Stream

[Bug 23763] Separate MIME type from Stream or not

[Bug 23768] [Shadow]: Consider using respec.js

[Bug 23769] [Shadow]: Event retargeting algorithm should consider the case of multiple shadow roots.

[Bug 23770] [Shadow]: A shadow tree of a younger shadow root should be a child tree of a shadow tree of the older shadow root in tree of trees.

[Bug 23798] [Shadow]: Use the feature of 'References' supported by ReSpec and remove Dependencies section

[Bug 23813] [Shadow]: Use the 'autolink' feature and get rid of hardcoded links to external definitions.

[Bug 23814] [Explainer]: Scoped evaluation of Script tag for custom elements and decorator events

[Bug 23946] Lift the ban on query parts in “blob:” URIs

[Bug 23973] [Streams API] Introduce in-band error signaling

[Bug 23974] [Streams API] Don't inherit object URL feature

[Bug 23975] [Streams API] Remove read as Blob support

[Bug 23977] [Streams API] Generic object stream

[Bug 24002] [imports]: import attribute on the LinkImport interface should be |Document?| instead of |Document|

[Bug 24003] [Imports]: Element removed flag's behavior is not clear if multiple HTMLLinkElement refers to the same import

[Bug 24009] [Shadow]: RELATED-PATH is not defined in "related target resolution algorithm"

[Bug 24011] [Shadow]: Typos

[Bug 24022] [Streams API] Lazily encode write()-en DOMString

[Bug 24023] [Streams API] Returned promise of write() should be fulfilled with current available space size rather than how many bytes were written

[Bug 24072] Clarify handling of neutered objects

[Bug 24074] new Worker('data:...') should not throw

[Bug 24077] second-argument-null.html worker test is incorrect

[Bug 24079] Test for initErrorEvent is invalid

[Bug 24087] [Custom]: Rename document.register to registerElement

[Bug 24101] Missing word in "Return the readAsText() method, but continue to process the steps in this algorithm"

[Bug 24102] Specify the targets for events

[Bug 24114] [imports]: add support for async loading

[Bug 24147] "The URL and documentURI attributes must return ..."

[Bug 24174] < should be quoted in attribute values

[Bug 24176] Clarify that custom SVG elements must extend an existing SVGElement

[Bug 24178] [Custom]: No way to differentiate attribute namespaces in attributeChanged callback

[Bug 24181] [Shadow]: There's isn't a way to append shadow elements in SVG

[Bug 24184] New: References undefined type EventHandler

[Bug 24184] References undefined type EventHandler

[Bug 24196] "equivalent to a DOMTokenList object without an ..."

[Bug 24196] New: "equivalent to a DOMTokenList object without an ..."

[Bug 24208] New: Please handle the case of XML attributes with namespaces but no prefix

[Bug 24210] New: Please handle the case of XML attributes with namespaces but no prefix

[Bug 24211] New: < should be quoted in attribute values

[Bug 24232] New: The containing block of fixpos elements in the top layer shouldn't be the ICB

[Bug 24232] The containing block of fixpos elements in the top layer shouldn't be the ICB

[Bug 24241] Adopt the ES6 "safe integer" range for (unsigned) long longs

[Bug 24241] New: Adopt the ES6 "safe integer" range for (unsigned) long longs

[Bug 24247] New: "guidelines for selecting and defining key values" is a dead link

[Bug 24248] Inconsistency between WebIDL callback function default this and JS strict mode default this

[Bug 24248] New: Inconsistency between WebIDL callback function default this and JS strict mode default this

[Bug 24268] [imports]: Imported documents should obey CSP on master document.

[Bug 24268] New: [imports]: imported documents should obey CSP on master document.

[Bug 24271] Document.createElement name validation inconsistent with HTML parse rules

[Bug 24271] New: Document.createElement name validation inconsistent with HTML parse rules

[Bug 24287] [Shadow]: Fix indents.

[Bug 24287] New: [Shadow]: Fix indents.

[Bug 24288] [Shadow]: Revert <shadow> element as a function call feature.

[Bug 24288] New: [Shadow]: Revert <shadow> element as a function call feature.

[Bug 24291] Add a Promise type to WebIDL, and make it not distinguishable from anything

[Bug 24291] New: Add a Promise type to WebIDL, and make it not distinguishable from anything

[Bug 24314] [Custom]: enteredView and leftView callbacks are still confusing

[Bug 24314] New: [Custom]: enteredView and leftView callbacks are still confusing

[Bug 24316] [Shadow]: implement :ancestor and change :host behavior

[Bug 24316] New: [Shadow]: implement :ancestor and change :host behavior

[Bug 24318] Define the Realm of objects

[Bug 24318] New: Define the Realm of objects

[Bug 24338] New: Spec should have Fetch for Blob URLs

[Bug 24338] Spec should have Fetch for Blob URLs

[Bug 24339] File API should specify Blob.close() with a state in the model and influence on read methods

[Bug 24339] New: File API should specify Blob.close() with a state in the model and influence on read methods

[Bug 24349] [imports]: Import documents should always be in no-quirks mode

[Bug 24349] New: [imports]: Import documents should always be in no-quirks mode

[Bug 24351] [Shadow]: Event related target resolution algorithm should consider the case of multiple shadow roots.

[Bug 24351] New: [Shadow]: Event related target resolution algorithm should consider the case of multiple shadow roots.

[Bug 24398] [Explainer]: typo ":" should be "="

[Bug 24398] New: [Explainer]: typo ":" should be "="

[Bug 24401] abort() should always dispatch loadend

[Bug 24401] New: abort() should always dispatch loadend

[Bug 24403] New: WebIDL callbacks should probably default to pushing a new entry settings object

[Bug 24403] WebIDL callbacks should probably default to pushing a new entry settings object

[Bug 24412] consider throwing RangeError instead of TypeError for invalid enum values

[Bug 24412] New: consider throwing RangeError instead of TypeError for invalid enum values

[Bug 24413] New: consider adding Interface.isInterface() functions

[Bug 24417] [Exposed] on an interface that is "implements"ed into another should mean something

[Bug 24417] New: [Exposed] on an interface that is "implements"ed into another should mean something

[Bug 24418] "langauge"

[Bug 24418] New: "langauge"

[Bug 24421] [Shadow]: Clarify that Shadow DOM spec takes care of nodes which are *inDocument*.

[Bug 24421] New: [Shadow]: Clarify that Shadow DOM spec takes care of nodes which are *inDocument*.

[Bug 24445] [Streams API] The Promise returned by write() method should tell the result of the write()

[Bug 24445] New: [Streams API] The Promise returned by write() method should tell the result of the write()

[Bug 24453] New: Expose interfaces to workers

Last message date: Friday, 31 January 2014 23:18:37 UTC