public-web-nfc@w3.org from October 2019 by subject

[web-nfc] "typedef DOMString NDEFRecordType" is expected to be case sensitive or not? (#331)

[web-nfc] A record might have no payload (#309)

[web-nfc] Accept BufferSource data for text records (#406)

[web-nfc] Add a bit more clarification about local type (#411)

[web-nfc] Add data attribute to NDEFRecord (#377)

[web-nfc] Add icon to spec and README (#426)

[web-nfc] Allow a NFC tap to load a URL with NFC message payload passed to the page (#78)

[web-nfc] android.nfc.NdefRecord.createXXX() does not have a parameter for record's id (#410)

[web-nfc] Avoid creating custom errors (#391)

[web-nfc] Change 'Web NFC API' to 'Web NFC' consistently (#405)

[web-nfc] Change `toRecords()` to `records` (#362)

[web-nfc] Consider renaming NFCReader etc to NDEFReader (#388)

[web-nfc] Data Mapping part is missing toRecords() (#354)

[web-nfc] Do we want to add support for writing sub records? (#357)

[web-nfc] Editorial changes around exposing NFC standards related text (#361)

[web-nfc] Find a new name for MIME media-type records (#393)

[web-nfc] Fix #393: change 'media' to 'mime' (#399)

[web-nfc] Fix random typos (#413)

[web-nfc] Handling non-formatted tags (#367)

[web-nfc] How much needs to be hidden from pages that lose focus during NFC operations? (#53)

[web-nfc] ignore media type for anything but mime (#415)

[web-nfc] Improve data mapping (#373)

[web-nfc] Improve info around encoding (#376)

[web-nfc] Introduce .encoding and .lang (#381)

[web-nfc] local type are well-known not external (#390)

[web-nfc] local types need some prefix of a kind (#375)

[web-nfc] Missing some record types in the algo creating ndef messages (#408)

[web-nfc] NDEFRecord mediaType should be non null for media records (#387)

[web-nfc] new commits pushed by kenchris

[web-nfc] new commits pushed by zolkis

[web-nfc] No 'id' field in NDEFMessageSource (#374)

[web-nfc] Notify NFCReaders of failures when trying to get a message from a tag? (#279)

[web-nfc] Notify user activation on NFC tap. (#368)

[web-nfc] Parse unknown records to mime records? (#421)

[web-nfc] Pull Request: Accept BufferSource data for text records

[web-nfc] Pull Request: Add a bit more clarification about local type

[web-nfc] Pull Request: Add data attribute to NDEFRecord

[web-nfc] Pull Request: Add icon to spec and README

[web-nfc] Pull Request: Add new co-editor

[web-nfc] Pull Request: Add unknown record JS example

[web-nfc] Pull Request: Added precision to local types

[web-nfc] Pull Request: Change 'Web NFC API' to 'Web NFC' consistently

[web-nfc] Pull Request: Change recordType url to absolute-url for Absolute-URL record

[web-nfc] Pull Request: Change unknown record recordType from mime to unknown

[web-nfc] Pull Request: Don't restrict toArrayBuffer to json and opaque records

[web-nfc] Pull Request: Don't wrap smart-poster and absolute-url in tables

[web-nfc] Pull Request: Editorial changes around exposing NFC standards related text

[web-nfc] Pull Request: Emphasize code of conduct in README

[web-nfc] Pull Request: Fix #282 - visibility change

[web-nfc] Pull Request: Fix #393: change 'media' to 'mime'

[web-nfc] Pull Request: fix external type record example

[web-nfc] Pull Request: Fix nit in example

[web-nfc] Pull Request: Fix nits in examples

[web-nfc] Pull Request: Fix random typos

[web-nfc] Pull Request: ignore media type for anything but mime

[web-nfc] Pull Request: Improve data mapping

[web-nfc] Pull Request: Improve info around encoding

[web-nfc] Pull Request: Introduce .encoding and .lang

[web-nfc] Pull Request: local type are well-known not external

[web-nfc] Pull Request: Remove "API" in title

[web-nfc] Pull Request: Remove "json" recordType

[web-nfc] Pull Request: Remove deprecated url key in example

[web-nfc] Pull Request: Remove IDL folder

[web-nfc] Pull Request: Remove NDEFErrorEvent

[web-nfc] Pull Request: Remove NDEFPushOptions timeout

[web-nfc] Pull Request: Remove text(), json(), and arrayBuffer()

[web-nfc] Pull Request: Rename toText, toJSON, and ToArrayBuffer NDEFRecord methods

[web-nfc] Pull Request: Revert "Add data attribute to NDEFRecord"

[web-nfc] Pull Request: s/ArrayBuffer/BufferSource/g in NDEFRecordInit data

[web-nfc] Pull Request: s/Google Inc./Google LLC

[web-nfc] Pull Request: s/NFC/NDEF/g in NFC interfaces and dictionaries.

[web-nfc] Pull Request: Some type fixes and mapping table improvements

[web-nfc] Pull Request: Throw TypeError if mediaType for non mime records

[web-nfc] Pull Request: Update mapping string to NDEF

[web-nfc] Pull Request: Use ReSpec syntax when possible

[web-nfc] push and scan should be gated by user activation (#425)

[web-nfc] Remove "API" in title (#404)

[web-nfc] Remove "json" recordType (#380)

[web-nfc] Remove idl folder (#389)

[web-nfc] Remove NDEFPushOptions ignoreRead (#424)

[web-nfc] Remove NDEFPushOptions timeout (#418)

[web-nfc] Remove NDEFPushOptions timeout (#428)

[web-nfc] Remove text(), json(), and arrayBuffer() (#384)

[web-nfc] Rename toText, toJSON, and ToArrayBuffer NDEFRecord methods (#370)

[web-nfc] s/ArrayBuffer/BufferSource/g in NDEFRecordInit data (#382)

[web-nfc] Some type fixes and mapping table improvements (#394)

[web-nfc] Spec disagrees with Security section (#420)

[web-nfc] Support Handover records (#364)

[web-nfc] Support Signature records (#363)

[web-nfc] Throw TypeError if mediaType for non mime records (#419)

[web-nfc] Update mapping string to NDEF (#407)

[web-nfc] User feedback: PWA integration (#429)

[web-nfc] Using streams (#369)

[web-nfc] We should add a section called "Local type record" - it is missing (#396)

[web-nfc] Web-NFC status question (#159)

[web-nfc] What's the definition of "a standard local type to smart poster or a handover record"? (#409)

[web-nfc] What's the value of `toJSON()`? (#366)

[web-nfc] Why returning null in arrayBuffer() from text, URL, and external record type? (#371)

[web-nfc] Wrong Absolute-URL recordType in Data Mapping? (#414)

Closed: [web-nfc] A record might have no payload (#309)

Closed: [web-nfc] After removing special record, get rid of Web NFC message terminology (#343)

Closed: [web-nfc] android.nfc.NdefRecord.createXXX() does not have a parameter for record's id (#410)

Closed: [web-nfc] Avoid creating custom errors (#391)

Closed: [web-nfc] Change `toRecords()` to `records` (#362)

Closed: [web-nfc] Consider renaming NFCReader etc to NDEFReader (#388)

Closed: [web-nfc] Do we want to add support for writing sub records? (#357)

Closed: [web-nfc] Find a new name for MIME media-type records (#393)

Closed: [web-nfc] Handling non-formatted tags (#367)

Closed: [web-nfc] How much needs to be hidden from pages that lose focus during NFC operations? (#53)

Closed: [web-nfc] local type are well-known not external (#390)

Closed: [web-nfc] Make sure we support sub-records AKA NDEF message as payload (#336)

Closed: [web-nfc] NDEFRecord mediaType should be non null for media records (#387)

Closed: [web-nfc] No 'id' field in NDEFMessageSource (#374)

Closed: [web-nfc] Parse unknown records to mime records? (#421)

Closed: [web-nfc] Remove idl folder (#389)

Closed: [web-nfc] Remove NDEFPushOptions timeout (#418)

Closed: [web-nfc] Smart Poster Well-Known doesn't seem to actually store a URL itself (#245)

Closed: [web-nfc] The link to 'focus' is not appropriate (#282)

Closed: [web-nfc] What's the definition of "a standard local type to smart poster or a handover record"? (#409)

Closed: [web-nfc] What's the value of `toJSON()`? (#366)

Closed: [web-nfc] Why returning null in arrayBuffer() from text, URL, and external record type? (#371)

Closed: [web-nfc] Wrong Absolute-URL recordType in Data Mapping? (#414)

New co-editor for Web NFC API

Last message date: Thursday, 31 October 2019 19:20:13 UTC