W3C home > Mailing lists > Public > public-sysapps@w3.org > May 2013

Rename "Web Alarms API" to "Task Scheduler"

From: Mounir Lamouri <mounir@lamouri.fr>
Date: Wed, 15 May 2013 17:01:17 +0100
Message-ID: <5193B14D.5060005@lamouri.fr>
To: "public-sysapps@w3.org" <public-sysapps@w3.org>

I would like to start a few discussions regarding the outstanding issues
we currently have with the Alarm API. To keep things simpler, I will
restrict every thread to one topic.

First of all, we should change the name of this specification. I think
that everybody will agree that the name is terrible, doesn't reflect
what we want to do and let people believe it is trying to do things it
isn't really designed for.

To start the discussion, I would like to propose to rename the
specification "Task Scheduler". Task is unfortunately used in other
specifications like HTML [1] but the naming isn't too overloaded and the
closest name I can think of would be "event" which is way too much used
in the Web Platform.

If the specification is renamed "Task Scheduler", I think we should
rename the "Alarm" interface "ScheduledTask".

Any thoughts on this?


Received on Wednesday, 15 May 2013 16:01:49 UTC

This archive was generated by hypermail 2.4.0 : Thursday, 1 July 2021 16:04:43 UTC