Re: Rename "Web Alarms API" to "Task Scheduler"

+ 1 to renaming

On 2013年05月16日 00:01, Mounir Lamouri wrote:
> Hi,
> I would like to start a few discussions regarding the outstanding issues
> we currently have with the Alarm API. To keep things simpler, I will
> restrict every thread to one topic.
> First of all, we should change the name of this specification. I think
> that everybody will agree that the name is terrible, doesn't reflect
> what we want to do and let people believe it is trying to do things it
> isn't really designed for.
> To start the discussion, I would like to propose to rename the
> specification "Task Scheduler". Task is unfortunately used in other
> specifications like HTML [1] but the naming isn't too overloaded and the
> closest name I can think of would be "event" which is way too much used
> in the Web Platform.
> If the specification is renamed "Task Scheduler", I think we should
> rename the "Alarm" interface "ScheduledTask".
> Any thoughts on this?
> [1]
> Thanks,
> --
> Mounir

Hsin-Yi Tsai 蔡欣宜
Mozilla Taiwan
T: +886-2-87861100 ext:312

Received on Thursday, 16 May 2013 02:28:06 UTC