RE: Rename "Web Alarms API" to "Task Scheduler"

+1 to name change!


>-----Original Message-----
>From: Mounir Lamouri []
>Sent: Wednesday, May 15, 2013 11:01 AM
>Subject: Rename "Web Alarms API" to "Task Scheduler"
>I would like to start a few discussions regarding the outstanding issues we
>currently have with the Alarm API. To keep things simpler, I will restrict every
>thread to one topic.
>First of all, we should change the name of this specification. I think that
>everybody will agree that the name is terrible, doesn't reflect what we want
>to do and let people believe it is trying to do things it isn't really designed for.
>To start the discussion, I would like to propose to rename the specification
>"Task Scheduler". Task is unfortunately used in other specifications like HTML
>[1] but the naming isn't too overloaded and the closest name I can think of
>would be "event" which is way too much used in the Web Platform.
>If the specification is renamed "Task Scheduler", I think we should rename the
>"Alarm" interface "ScheduledTask".
>Any thoughts on this?


This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

Received on Wednesday, 15 May 2013 16:03:58 UTC