W3C home > Mailing lists > Public > public-socialweb@w3.org > March 2015

Re: Deprecate "actor" in favor of "attributeTo"

From: Bill Looby <bill_looby@ie.ibm.com>
Date: Tue, 24 Mar 2015 21:23:07 +0000
To: Evan Prodromou <evan@e14n.com>
Cc: public-socialweb@w3.org
Message-ID: <OF915DD4E4.74C99F07-ON80257E12.00743923-80257E12.007579E8@ie.ibm.com>
Had the same first reaction, based primarily on 'actor' being more 

attributedTo also feels less exact regarding the persons relationship to 
the event, as we lose the notion of action, but the only (very 
unconvincing) example I can think of is that attributedTo could 
theoretically refer to either the actor (this event is attributed to Jane 
who commented on Joes Blog entry) or to the sender (this event is 
attributed to Joe, who hosts the referenced blog) of the event.

Bill Looby
Software Architect, Dublin Software Lab, IBM Ireland
IBM UK & Ireland Technical Staff Member
Phone (Internal) : 515129
Phone (External) : +353 1 8155129
IBM Ireland Product Distribution Limited registered in Ireland with number 
92815.  Registered office: IBM House, Shelbourne Road, Ballsbridge, Dublin 

From:   Evan Prodromou <evan@e14n.com>
To:     public-socialweb@w3.org
Date:   24/03/2015 20:11
Subject:        Re: Deprecate "actor" in favor of "attributeTo"

I prefer "actor".

"actor" seems much more readable and understandable.

"attributedTo" seems indirect, passive, and uncertain. "Who attributes 
this action to this agent? Why? Are they potentially wrong?"


On 2015-03-24 04:02 PM, James M Snell wrote:
> In the most recent published working draft, the "author" property was
> replaced by a more generalized "attributedTo" property. "author" is
> still in there but is listed among the deprecated AS 1.0 terms. The
> "actor" property on Activities is currently defined as a sub-property
> of "attributedTo". Moving forward, there's likely very little value in
> having the separate "actor" property. We can simplify and consolidate
> down to just using "attributedTo". "actor" would be moved into the
> deprecated set for backwards compatibility.
> So instead of:
>    {
>      "@type": "Like",
>      "actor": "http://joe.example.org",
>      "object": "http://example.org/posts/1"
>    }
> It would be:
>    {
>      "@type": "Like",
>      "attributedTo": "http://joe.example.org",
>      "object": "http://example.org/posts/1"
>    }
> Note: this proposal does not ADD anything to the vocabulary, it
> removes. Which is a good thing.
Received on Tuesday, 24 March 2015 21:23:41 UTC

This archive was generated by hypermail 2.3.1 : Thursday, 8 December 2016 15:48:21 UTC