W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2013

Re: an idea for replacing arguments.length

From: Boris Zbarsky <bzbarsky@MIT.EDU>
Date: Tue, 12 Nov 2013 19:59:43 -0500
Message-ID: <5282CEFF.4050803@mit.edu>
To: Brendan Eich <brendan@mozilla.com>
CC: Allen Wirfs-Brock <allen@wirfs-brock.com>, "public-script-coord@w3.org" <public-script-coord@w3.org>, es-discuss@mozilla.org
On 11/12/13 7:19 PM, Brendan Eich wrote:
> What "semantic problem" required two createTouchList functions having
> the same name?

The fact that some UAs shipped one version of it others shipped another 
(as the spec evolved), then the working group decided to spec one of 
those versions but there was already code in the wild using the other 
version, so those UAs are now just supporting both signatures to avoid 
breaking that code.

> Isn't that a design choice?

Sure.  A bad one; the working group should have changed the name when 
they changed the semantics.

> If so, then I am arguing it was the wrong choice, but "looked ok" by precedent including WebIDL
> support.

It didn't look ok.  They just made a backwards-incompatible change, period.

> Whatever I'm trying to affect, the idea is norms

Sure.  My point is that in this particular case the "norm" of overloads 
in WebIDL wasn't the real norm that got broken.  The "don't break 
shipping stuff" norm was the real issue.

> What spec of
> doc should promulgate a norm that says "use a different name" for the
> second createTouchList?

You mean "don't effing randomly break backwards compat"?  No spec for 
that, sadly.

Received on Wednesday, 13 November 2013 01:00:14 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:19 UTC