W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2013

Re: an idea for replacing arguments.length

From: Brendan Eich <brendan@mozilla.com>
Date: Tue, 12 Nov 2013 16:19:52 -0800
Message-ID: <5282C5A8.5010409@mozilla.com>
To: Boris Zbarsky <bzbarsky@MIT.EDU>
CC: Allen Wirfs-Brock <allen@wirfs-brock.com>, "public-script-coord@w3.org" <public-script-coord@w3.org>, es-discuss@mozilla.org
Boris Zbarsky wrote:
>> Oh, ok -- new-ish legacy. This makes the case for stronger normative
>> specs against such overloading, starting with WebIDL.
>
> Again, WebIDL disallowing this would not have helped; the real issue 
> was a semantic problem.

What "semantic problem" required two createTouchList functions having 
the same name? Isn't that a design choice? If so, then I am arguing it 
was the wrong choice, but "looked ok" by precedent including WebIDL support.

> I'm all for simplifying the overloading that WebIDL supports, but it 
> wouldn't have affected this case.

Whatever I'm trying to affect, the idea is norms, not outright bans or 
removals of code required for backward compatibility. If createTouchList 
is relatively new, then I bet there will be a "next time". What spec of 
doc should promulgate a norm that says "use a different name" for the 
second createTouchList?

/be
Received on Wednesday, 13 November 2013 00:20:21 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:19 UTC