Re: RDFa API - graph?

On Sat, Oct 30, 2010 at 5:03 PM, Nathan <> wrote:
> Hi All,
> Just a small thought.. it dawned on me this morning that Graph or RDFGraph
> may be a better / alternative name for DataStore - personally when I
> mentally swap out all mentions of store for graph in examples, design and
> text things feel that bit clearer
>  graph.add(triple);
>  graph.merge(otherGraph);
>  serialize(graph);
>  graph.filter(myFilter);
> and so forth, it clearly separates the concepts of "Store" (somewhere to
> store graphs and triples) and "Graph" (a set of triples, an RDF Graph),
> further, graph is a common concept in the RDFa Core documentation, and all
> RDF documentation which goes unrepresented in the RDFa API.
> Anyway, just a thought, I'm sure you get the idea - any opinions?

+1 for this. In RDF.rb [1], we have repositories and graphs, where
repositories contain one or more graphs, and those graphs then contain
a set of triples each. So, I'd have to agree that "Graph" is a better
name than "DataStore" for a container of triples.

Best regards,


Arto Bendiken | @bendiken @datagraph

Received on Saturday, 30 October 2010 15:19:26 UTC