W3C home > Mailing lists > Public > public-rdfa-wg@w3.org > October 2010

Re: RDFa API - graph?

From: Shane McCarron <shane@aptest.com>
Date: Sat, 30 Oct 2010 10:48:35 -0500
Message-ID: <4CCC3E53.7000301@aptest.com>
To: Arto Bendiken <arto.bendiken@gmail.com>
CC: Nathan <nathan@webr3.org>, RDFA Working Group <public-rdfa-wg@w3.org>
+1.

however, playing devil's advocate for a moment... the problem with 
'graph' is that people who don't grok RDF (like me) surely won't grok 
what a 'graph' is.  'graph' is a very computer-sciency term.  It's the 
right term in this case.  The problem is that as our audience expands 
beyond computer scientists to web designers who just want to easily 
access semantic information from a web page... those people are not in 
general classically trained CSci majors like some of us surely are.  I 
still think this is the right term.  But a glossary or short definition 
of the term might help the great unwashed out there.

On 10/30/2010 10:18 AM, Arto Bendiken wrote:
> On Sat, Oct 30, 2010 at 5:03 PM, Nathan<nathan@webr3.org>  wrote:
>> Hi All,
>>
>> Just a small thought.. it dawned on me this morning that Graph or RDFGraph
>> may be a better / alternative name for DataStore - personally when I
>> mentally swap out all mentions of store for graph in examples, design and
>> text things feel that bit clearer
>>
>>   graph.add(triple);
>>   graph.merge(otherGraph);
>>   document.data.graph;
>>   serialize(graph);
>>   graph.filter(myFilter);
>>
>> and so forth, it clearly separates the concepts of "Store" (somewhere to
>> store graphs and triples) and "Graph" (a set of triples, an RDF Graph),
>> further, graph is a common concept in the RDFa Core documentation, and all
>> RDF documentation which goes unrepresented in the RDFa API.
>>
>> Anyway, just a thought, I'm sure you get the idea - any opinions?
> +1 for this. In RDF.rb [1], we have repositories and graphs, where
> repositories contain one or more graphs, and those graphs then contain
> a set of triples each. So, I'd have to agree that "Graph" is a better
> name than "DataStore" for a container of triples.
>
> Best regards,
> Arto
>
> [1] http://rdf.rubyforge.org/
>

-- 
Shane P. McCarron                          Phone: +1 763 786-8160 x120
Managing Director                            Fax: +1 763 786-8180
ApTest Minnesota                            Inet: shane@aptest.com
Received on Saturday, 30 October 2010 15:49:14 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:05:22 UTC