Renaming sd:AggregateFunction

Based on our previous discussion I was going to renamed sd:AggregateFunction to sd:Aggregate, but ran into a few snags.

Currently in the service description doc, I've got this:

> sd:AggregateFunction a rdfs:Class ;
> 	rdfs:subClassOf sd:Function ;
> 	rdfs:label "An instance of sd:AggregateFunction represents an extension function that may be used in a SPARQL aggregate query HAVING clause or project expression." .
> sd:extensionFunction a rdf:Property ;
> 	rdfs:subPropertyOf sd:feature ;
> 	rdfs:domain sd:Service ;
> 	rdfs:range sd:Function ;
> 	rdfs:label "Relates an instance of sd:Service to a function that is supported as either a scalar, value testing function (as described in SPARQL 11.6) or an aggregate function. The rdf:type of the function may be used to indicate which of these function types apply, being either sd:ScalarFunction or sd:AggregateFunction." .

So you could indicate that your endpoint supports a custom aggregate with:

> [] a sd:Service ; sd:extensionFunction ex:myAggregate .

Does anyone have thoughts on how that should be aligned with a renaming of sd:AggregateFunction to indicate that it's not really a function? Maybe we add a new property sd:extensionAggregate that is a subproperty of sd:feature?


Received on Sunday, 18 April 2010 18:39:22 UTC