Re: Little PROV-O questions

Simon (and Luc),

On Jan 16, 2013, at 3:51 AM, "Miles, Simon" <> wrote:

> Hello PROV-O authors,
> From doing some implementation based on the PROV-O and PROV-DM specs, I noticed a few things that could be clarified.
> 1. Two terms defined in PROV-DM are not part of PROV-O and it's not clearly set out how the same concepts should be expressed in PROV-O. In particular, PROV-DM definitions use attribute prov:type. I believe, from previous mails, that this should be expressed as rdf:type in PROV-O data, but I couldn't find it documented.

You are correct, PROV-O uses rdf:type to express prov:type.
You are also correct that this was not explicitly stated in the HTML document.
I've added a note into

@Luc, would it make sense to make entries for "type" and "label" in ?

> Similarly, I couldn't find information on how to encode prov:label, which is asked about in the implementation questionnaire maybe implying it could be used with PROV-O (I assume it maps to rdfs:label).

Yes, this is included in the change I mention above.

> 2. I noticed that qualifiedPrimarySource, qualifiedRevision and qualifiedQuotation are subproperties of qualifiedInfluence, but not of qualifiedDerivation. This seems inconsistent with the binary relations, hadPrimarySource, wasRevisedFrom and wasQuotedFrom which are subproperties of wasDerivedFrom.

.. and also inconsistent with the subclass hierarchy, where e.g. Revision is a subclass of Derivation.
We changed the class hierarchy in response to Alan's
So, the natural direction for "readability" would be to make the qualified* sub properties of qualifiedDerivation.
But we can't make the change this far along.
Fortunately, the qualification properties are of a different breed than the binary properties and the classes, so we can justify the distinction.
And, the ranges of the qualified{Revision,PrimarySource,Quotation} are to the specific classes Revision,PrimarySource,Quotation -- which are now subclasses of Derivation thanks to Alan in his issue above.
So, it all still works out.

> Maybe I don't understand the rationale or missed it on the mailing list, but thought I'd point it out.


> 3. I think the definition/description of prov:value could be better: "The main value (if there is one) of a structured value." Should the second "value" be another term?

This was out of date. What is shown was prov-o editorial and taken from rdf:value's definition.
i've updated the prov:value to be from DM: 

provides a value that is a direct representation of an entity



> thanks,
> Simon
> Dr Simon Miles
> Senior Lecturer, Department of Informatics
> Kings College London, WC2R 2LS, UK
> +44 (0)20 7848 1166
> Transparent Provenance Derivation for User Decisions:

Received on Tuesday, 12 February 2013 14:30:25 UTC