W3C home > Mailing lists > Public > public-hydra@w3.org > June 2014

RE: Hydra scope

From: McBennett, Pat <McBennettP@DNB.com>
Date: Wed, 4 Jun 2014 04:48:17 -0500
To: David Booth <david@dbooth.org>, "public-hydra@w3.org" <public-hydra@w3.org>
Message-ID: <52EE3F4A5E7F194A963FE14B2DDBDBFE2CAB39906A@DNBEXCH01.dnbint.net>
> -----Original Message-----
> From: David Booth [mailto:david@dbooth.org]
> Sent: Tuesday, June 03, 2014 8:33 PM
> To: public-hydra@w3.org
> Subject: Re: Hydra scope
> On 06/03/2014 02:39 PM, Markus Lanthaler wrote:
> > You do realize that we have both "operation" and "supportedOperation"
> > at the moment, right? "operation" is used to describe what operations
> > are supported by that specific resource whereas "supportedOperation"
> > allows to describe what operations are supported by all instances of
> > the class it is used on (or all values of the property it is used on).
> > In that sense, supportedProperties is consistent at it tells you what
> > properties that server supports for instances of that class.
> A small naming suggestion: If I'm understanding correctly, both "operation"
> and "supportedOperation" describe what operations are supported, but one
> describes what operations are supported a specific instance whereas the
> other describes what operations are supported by all instances of the class.
> If that is the distinction, I would suggest choosing names that somehow
> reflect that distinction.
> Thanks,
> David

+1 (since the distinction wasn't that clear to me initially either)

So for openers, how about 'classOperation' (since we already have hydra:Class) and 'instanceOperation'?! I guess it would mean also changing 'supportedProperties' to 'instanceProperties'.

Being an Object-Oriented developer I'm comfortable with that terminology, but are those terms really accurate, and are they too much for Hydra users to understand in general...?
Received on Wednesday, 4 June 2014 09:48:47 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 15:53:59 UTC