W3C home > Mailing lists > Public > public-device-apis@w3.org > July 2014

Re: [battery] Moving Battery API forward, next steps?

From: Kostiainen, Anssi <anssi.kostiainen@intel.com>
Date: Wed, 2 Jul 2014 06:47:40 +0000
To: "cathy.chan@nokia.com" <cathy.chan@nokia.com>
CC: "timvolodine@google.com" <timvolodine@google.com>, "frederick.hirsch@nokia.com" <frederick.hirsch@nokia.com>, "public-device-apis@w3.org" <public-device-apis@w3.org>, "ldeluca@us.ibm.com" <ldeluca@us.ibm.com>
Message-ID: <9A8B3BF0-80F8-4C4E-BFB4-531DBDAC2A4B@intel.com>

On 01 Jul 2014, at 18:22, <cathy.chan@nokia.com> <cathy.chan@nokia.com> wrote:

>> From: ext Kostiainen, Anssi [mailto:anssi.kostiainen@intel.com]
>> On 26 Jun 2014, at 20:57, Tim Volodine <timvolodine@google.com> wrote:
>>> 2. multiple batteries:
>>> level -- instead of "sum" of levels it should be "average",
>>> dischargingTime -- should be max dischargingTime if in parallel and sum if in
>> series.
>> Fixed:
>> https://dvcs.w3.org/hg/dap/rev/7857ba0e4266
> You forgot to remove the old and incorrect description for dischargingTime.
> Also, since the rule is practically the same for both charging time and discharging time (max if parallel, sum if serial), I would suggest using the same text for both attributes. That'd be much easier to read.
> [[
> The chargingTime attribute can be set to the maximum charging time of the individual batteries if charging in parallel, and to the sum of the individual charging times if charging serially. 
> The dischargingTime attribute can be set to the maximum discharging time of the individual batteries if discharging in parallel, and to the sum of the individual discharging times if discharging serially.
> ]]

Thanks Cathy! This is now fixed as per your suggestion. I also embellished the section a bit more:


Here’s the updated text in context:


Please let us know if spot any other spec bugs.


Received on Wednesday, 2 July 2014 06:48:16 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:33:10 UTC