W3C home > Mailing lists > Public > public-device-apis@w3.org > July 2014

RE: [battery] Moving Battery API forward, next steps?

From: <cathy.chan@nokia.com>
Date: Tue, 1 Jul 2014 15:22:25 +0000
To: <anssi.kostiainen@intel.com>, <timvolodine@google.com>
CC: <frederick.hirsch@nokia.com>, <public-device-apis@w3.org>, <ldeluca@us.ibm.com>
Message-ID: <00e46b5d193141d3a334245379b9e01b@NOKWDCFIEXCH02P.nnok.nokia.com>
> From: ext Kostiainen, Anssi [mailto:anssi.kostiainen@intel.com]
>
> On 26 Jun 2014, at 20:57, Tim Volodine <timvolodine@google.com> wrote:
> 
> > 2. multiple batteries:
> >
> > level -- instead of "sum" of levels it should be "average",
> > dischargingTime -- should be max dischargingTime if in parallel and sum if in
> series.
> 
> Fixed:
> 
> https://dvcs.w3.org/hg/dap/rev/7857ba0e4266
> 

You forgot to remove the old and incorrect description for dischargingTime.

Also, since the rule is practically the same for both charging time and discharging time (max if parallel, sum if serial), I would suggest using the same text for both attributes. That'd be much easier to read.
[[
The chargingTime attribute can be set to the maximum charging time of the individual batteries if charging in parallel, and to the sum of the individual charging times if charging serially. 
The dischargingTime attribute can be set to the maximum discharging time of the individual batteries if discharging in parallel, and to the sum of the individual discharging times if discharging serially.
]]

Regards, Cathy.
Received on Tuesday, 1 July 2014 15:22:57 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:33:10 UTC