Our recent editorial experiments were to use the terms SHACL instance, 
SHACL type and SHACL subclass. I don't find this very attractive to read 
and it gives room to misinterpretation too, e.g. people could read it as 
if we were using different properties than rdf:type or rdfs:subClassOf.

Looking at the RDFS spec [1], we can read

     "The rdfs:subClassOf property is transitive".

This is exactly the relevant bit of "inferencing" that we are using in 
SHACL too.

So why can't we switch to the terms

- transitive subclass
- transitive type
- transitive instance

which should be relatively unambiguous esp given that each usage of 
these terms is now hyperlinked to the terminology section. Furthermore 
transitivity even carries a fairly appropriate meaning:



Received on Monday, 16 May 2016 12:10:36 UTC