Re: [csswg-drafts] [css-shared-element-transitions-1] Renaming and brevity (#7788)

Just throwing out some ideas...

Using "swap" instead of "transition" as @astearns suggested and adding an image-pair wrapper to support nesting going forward...

```
::swap
::swap-view(header)
::swap-view-group(header)
::swap-view-old(header)
::swap-view-new(header)
```

or maybe

```
::view-swap
::view-swap-set(header)
::view-swap-pair(header)
::view-swap-old(header)
::view-swap-new(header)
```

(I don't quite like the confusion over whether sets or pairs are outermost.)

I think View Transitions is a very natural name for this feature, though, and keeping it in the pseudo names is long but also helpful?

-- 
GitHub Notification of comment by fantasai
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/7788#issuecomment-1266347088 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Tuesday, 4 October 2022 03:27:11 UTC