W3C home > Mailing lists > Public > public-css-archive@w3.org > May 2017

Re: [csswg-drafts] reconsider name of frames() timing function

From: Martin <sysbot+gh@w3.org>
Date: Fri, 05 May 2017 16:39:42 +0000
To: public-css-archive@w3.org
Message-ID: <issue_comment.created-299514412-1494002381-sysbot+gh@w3.org>
Hi from the slack.

When I came up with the name `frames()`, one of the major use cases for this timing function was spritesheet animations, which were hacky or required modifying the spritesheet or animation in a specific way (I think Rachel Nabors was having tricky time trying to use the `steps` function for this).

Root issue with the steps function is that when animating, the first & last step only appear in half the duration that the steps in the middle have, creating an inconsistent animation. This is especially noticeable with looping when passing the short last step and the short first step in succession.

If I remember correctly, older suggestions we had at the time were: `equal`, `distributed`, `divided` and various other synonyms. Also variations with step(s) as suffix or prefix as an alternate form.

shshaw from slack suggested `equal-step`

GitHub Notification of comment by Martin-Pitt
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/1301#issuecomment-299514412 using your GitHub account
Received on Friday, 5 May 2017 16:39:48 UTC

This archive was generated by hypermail 2.4.0 : Tuesday, 5 July 2022 06:41:12 UTC