W3C home > Mailing lists > Public > public-banana-rdf@w3.org > November 2014

Towards 0.7.1

From: Alexandre Bertails <alexandre@bertails.org>
Date: Mon, 10 Nov 2014 18:03:05 -0500
Message-ID: <CANvn8kxccawMMA6sRkcc2DF4GCNPnOBX6jsW==4wk1h+y3ENfQ@mail.gmail.com>
To: Public Banana-RDF <public-banana-rdf@w3.org>
0.7.0 was released, but it is a not a good release for several reasons
that I'll pass :-)

So for 0.7.1, we want to get it right.

On series. I propose that after we have successfully issued 0.7.1, we
follow scalaz naming conventions, for example having a `series/0.7.x`
branch where important fixes can be submitted. Until we reach a first
1.0.0 release, we will adopt the proper semantic versioning.

On releases. Looks like Maven Central is ok now. We also have a
request for publishing on Bintray as well, which might be the best
option for SNAPSHOT. Any objections with using the `banana-rdf`

Also, Alistair was suggesting a bunch of plugins to make the release
process smoother, I guess we want them all working to declare victory
on 0.7.1.

On naming. We had discussions on dropping the `_jvm` suffix that was
introduced with scala-js. I would like us to have the final discussion
here. In a nutshell, Alistair prefers keeping the suffix to make
things more explicit, while Anton and I believe it is unnecessary as
an absence of suffix is everywhere else already the default for
targetting the JVM. We would still keep `_js` for scala-js project,
eg. `rdfstore_js`.

On dependencies. We still have to merge Henry's fix for the ntriples
module dependency. But that should happen on 0.7.1-SNAPSHOT.

I would prefer we that we don't squeeze anything new in 0.7.x and that
we focus on the release.


PS: so happy to have a proper mailing-list now :-)
Received on Monday, 10 November 2014 23:03:32 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 19:37:01 UTC