W3C home > Mailing lists > Public > public-banana-rdf@w3.org > November 2014

Re: Towards 0.7.1

From: <henry.story@bblfish.net>
Date: Tue, 11 Nov 2014 00:16:15 +0100
Cc: Public Banana-RDF <public-banana-rdf@w3.org>
Message-Id: <C5EC3142-821D-43E9-90D8-8C90B9FCD796@bblfish.net>
To: Alexandre Bertails <alexandre@bertails.org>
Great news.

  I suggest that the IRC channel and the mailing list be listed clearly
in the README on the front page.

  For all the rest I am ok, except that I'd like to be able to
add fixes for things that are needed for me to adapt rww-play 
to banana-rdf 0.7.1


We made a lot of changes recently, but I did not check each of these
changes on the current version of rww-play, so there are some changes
which break things in a way that is clearly not helpful.

  For example 

 is just a rollback of a change I made after a long discussion with alexander
where I kind of forgot why it was there in the first place.

 0.7.1 should not be less good than what we had a year ago.

  There may be one other case like that. Hopefully not. I am just adapting
my code. Perhaps I have done most of it allready.


> On 11 Nov 2014, at 00:03, Alexandre Bertails <alexandre@bertails.org> wrote:
> 0.7.0 was released, but it is a not a good release for several reasons
> that I'll pass :-)
> So for 0.7.1, we want to get it right.
> On series. I propose that after we have successfully issued 0.7.1, we
> follow scalaz naming conventions, for example having a `series/0.7.x`
> branch where important fixes can be submitted. Until we reach a first
> 1.0.0 release, we will adopt the proper semantic versioning.
> On releases. Looks like Maven Central is ok now. We also have a
> request for publishing on Bintray as well, which might be the best
> option for SNAPSHOT. Any objections with using the `banana-rdf`
> organization?
> Also, Alistair was suggesting a bunch of plugins to make the release
> process smoother, I guess we want them all working to declare victory
> on 0.7.1.
> On naming. We had discussions on dropping the `_jvm` suffix that was
> introduced with scala-js. I would like us to have the final discussion
> here. In a nutshell, Alistair prefers keeping the suffix to make
> things more explicit, while Anton and I believe it is unnecessary as
> an absence of suffix is everywhere else already the default for
> targetting the JVM. We would still keep `_js` for scala-js project,
> eg. `rdfstore_js`.
> On dependencies. We still have to merge Henry's fix for the ntriples
> module dependency. But that should happen on 0.7.1-SNAPSHOT.
> I would prefer we that we don't squeeze anything new in 0.7.x and that
> we focus on the release.
> Alexandre
> PS: so happy to have a proper mailing-list now :-)

Social Web Architect
Received on Monday, 10 November 2014 23:16:44 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 19:37:01 UTC