W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API updates

From: Anne van Kesteren <annevk@opera.com>
Date: Thu, 11 Jan 2007 00:24:17 +0100
To: "Dave Massy" <Dave.Massy@microsoft.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <op.tlyomrj764w2qv@id-c0020>

On Wed, 10 Jan 2007 19:14:46 +0100, Dave Massy <Dave.Massy@microsoft.com>  
wrote:
> Looking at the feedback on
> http://lists.w3.org/Archives/Public/public-webapi/ and Anne's blog entry
> at http://annevankesteren.nl/2006/12/selectors-api-naming it seems that
> the majority of people would agree with these principles and the
> suggested names based on getElementBySelector.

Just to make sure I understand what "majority" is I took my weblog entry  
and counted the various names. +1 are those in favor of the proposal, 0  
are those that didn't express any opinion and -1 are those against the  
proposal. Where "proposal" is the shorter name:

+1
   zcorpan
   Robert Sayre
   Aristotle *
   Henri
   (Anne van Kesteren)

0
   Arjan Eising
   Daniel Morrison
   Blaise
   Simon Jessey
   Daniel James
   Richard York
   Chaals
   Christian

-1
   minghong
   Arve
   Laurens Holst
   Jaap **
   Fatal
   Asbjørn Ulsberg


* Make sure you read the whole thread.

** Jaap later switched his mind when I switched to using get() and  
getAll() instead in  
http://annevankesteren.nl/2007/01/web-api-stuff#comment-5888 So he's now  
+1 I suppose. Given that we're not examining that blog entry I put him in  
-1.


-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>
Received on Wednesday, 10 January 2007 23:55:15 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT