Re: SOAP Arrays

 thank you for putting it in there. 8-)
 I have a few comments, corrections and amendments:

 section 3.4.2, 3rd paragraph seems to indicate that all
multi-reference value use the href attribute, while it's all but
one (the one that actually carries the value). I think it should
be rephrased.

 the BNF notation: I'd rename 'size' to be 'concreteSize' because 
the current name suggests that '*' is not a size. 

 last paragraph before the note: after the recent discussions on 
the differences between MUST,SHOULD and MAY, I'd reword the 
paragraph to the following:
 "A SOAP Encoding array MAY contain an enc:itemType attribute of
type QName. This type specifies the base type for the type of
every member of the array. The default value of this attribute is
xsd:anyType. Each member's type SHOULD be a subtype of itemType
or it must be the itemType itself. If a member does not specify 
its type, it is assumed to be the itemType."
 The weakening of MUST to SHOULD is so as not to require Schema 
processing. The added last sentence means to explain further the 
intent of the itemType attribute (not only a constraint on the 
members, also a default for the members' types).

 the Note: I'd add a sentence to the effect that Partial arrays 
and Sparse arrays and any other incomplete arrays can be conveyed 
as higher-level structures constructed of normal structs and 
complete arrays.

 I'll get to the examples later, I already know I will have some 
comments on the examples text, too. 8-)
 Best regards, 

                   Jacek Kopecky

                   Senior Architect, Systinet (formerly Idoox)

On Thu, 17 Jan 2002, Marc Hadley wrote:

 > Jacek,
 > I've integrated the work you did on SOAP arrays to the editors draft at
 > I would be grateful is you could review it and let me know if you spot 
 > any errors. I did a small amount of wordsmithing on the text, but 
 > nothing drastic ;-)
 > I have also updated the example which follow the text. The BNF for 
 > arraySizeValue may be wrong, I guessed on some parts of the notation.
 > Thanks,
 > Marc.

Received on Friday, 18 January 2002 04:53:41 UTC