W3C home > Mailing lists > Public > www-ws-desc@w3.org > May 2006

Re: Suggestion to change {safety} to {safe}

From: Jacek Kopecky <jacek.kopecky@deri.org>
Date: Wed, 31 May 2006 17:24:47 +0200
To: "John Kaputin (gmail)" <jakaputin@gmail.com>
Cc: www-ws-desc@w3.org, woden-dev@ws.apache.org
Message-Id: <1149089087.29161.8.camel@localhost>

Hi John,

the difference between {safety} and {required} is that for the latter,
false is not true, whereas for {safety} false is unclaimed. An operation
that doesn't claim to be safe can still be.

Therefore {safe} could be misleading. However, I'm not sure that
{safety} is non-misleading enough here. 8-)


On Wed, 2006-05-24 at 22:43 +0100, John Kaputin (gmail) wrote:
> A bit late in the day (sorry), but I'd like to suggest renaming the
> extension property {safety} to {safe} to better describe one of the
> binary states (safe vs unsafe) of this property, which in turn will
> map neatly to a boolean API method like isSafe(). It also reflects the
> discussion of this property in the spec which talks about operations
> being 'safe' or 'unsafe'.  getSafety() is cumbersome and isSafety()
> doesn't sound quite right.
> As an example, the {required} boolean property describes a binary
> state (required vs not required) that maps neatly to the boolean
> method isRequired().
> Our options in Woden are to just adopt the isXXX() convention for a
> boolean property {XXX} and not worry about how it sounds or diverge
> from the exact property-to-method naming convention we have been using
> and construct a more suitable boolean method name (i.e. for the
> boolean properties {http cookies} and {http location ignore uncited}).
> regards,
> John Kaputin.
Received on Wednesday, 31 May 2006 15:24:53 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:58 UTC