W3C home > Mailing lists > Public > www-ws-desc@w3.org > May 2006

Suggestion to change {safety} to {safe}

From: John Kaputin (gmail) <jakaputin@gmail.com>
Date: Wed, 24 May 2006 22:43:41 +0100
Message-ID: <4c2ae8f80605241443l1be13ff3j613abe9148cc3adb@mail.gmail.com>
To: www-ws-desc@w3.org
Cc: woden-dev@ws.apache.org
A bit late in the day (sorry), but I'd like to suggest renaming the
extension property {safety} to {safe} to better describe one of the binary
states (safe vs unsafe) of this property, which in turn will map neatly to a
boolean API method like isSafe(). It also reflects the discussion of this
property in the spec which talks about operations being 'safe' or 'unsafe'.
getSafety() is cumbersome and isSafety() doesn't sound quite right.

As an example, the {required} boolean property describes a binary state
(required vs not required) that maps neatly to the boolean method

Our options in Woden are to just adopt the isXXX() convention for a boolean
property {XXX} and not worry about how it sounds or diverge from the exact
property-to-method naming convention we have been using and construct a more
suitable boolean method name (i.e. for the boolean properties {http cookies}
and {http location ignore uncited}).

John Kaputin.
Received on Tuesday, 30 May 2006 18:33:06 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:58 UTC