Re: The attribute formerly known as "name"

Interesting, I am yet to receive the original message from Amy or Glen's 
follow-up but I have received this follw-up message. Anyhow I have not 
seen all proposals put forth but, I tend to agree with Glen that 
"messageReference" (or "messageRef") are good choices here. MessageRole 
would be a reasonable alternate as well.

P.S. is there a problem with the WSDL mailing list or am I the only one 
with this problem?

-------- Original Message --------
Subject: 	RE: The attribute formerly known as "name"
Resent-Date: 	Fri, 5 Sep 2003 14:11:37 -0400 (EDT)
Date: 	Fri, 5 Sep 2003 19:11:26 +0100
From: 	Savas Parastatidis <>
To: 	WS Description List <>


> "messageName" seems good to me, since that's what it is - the name of the
> message in the pattern spec.  "messageReference" (or "messageRef")would
> be good as well, since it makes it clear that this is a reference to an
> external document.
> --Glen

For what it's worth, I agree that a message is described and hence
"messageName" is appropriate. Without wanting to confuse matters further
I was wondering what people thought about the following suggestion.

Since WSDL defines the messages that are received/sent by a Web Service,
wouldn't it be more appropriate to rename "operation" to "messages" or
even "message-group"?

  <messages> or <message-group>
    <input messageName="..."/>
    <output messageName="..."/>
    <fault messageName="..."/>


    <input message="..."/>
    <output message="..."/>
    <fault message="..."/>

Would that confuse people more than it would help?

A web service is an agent that sends/receives messages and not an agent
that has operations (at least that's my understanding from the WSA

Just thinking aloud here.


Received on Friday, 5 September 2003 19:39:33 UTC