W3C home > Mailing lists > Public > www-ws-desc@w3.org > September 2003

RE: The attribute formerly known as "name"

From: Savas Parastatidis <Savas.Parastatidis@newcastle.ac.uk>
Date: Fri, 5 Sep 2003 19:11:26 +0100
Message-ID: <BC28A9E979C56C44BCBC2DED313A447002050916@bond.ncl.ac.uk>
To: "WS Description List" <www-ws-desc@w3.org>


> "messageName" seems good to me, since that's what it is - the name of
> message in the pattern spec.  "messageReference" (or "messageRef")
> be good as well, since it makes it clear that this is a reference to
> external document.
> --Glen

For what it's worth, I agree that a message is described and hence
"messageName" is appropriate. Without wanting to confuse matters further
I was wondering what people thought about the following suggestion.

Since WSDL defines the messages that are received/sent by a Web Service,
wouldn't it be more appropriate to rename "operation" to "messages" or
even "message-group"?

  <messages> or <message-group>
    <input messageName="..."/>
    <output messageName="..."/>
    <fault messageName="..."/>


    <input message="..."/>
    <output message="..."/>
    <fault message="..."/>

Would that confuse people more than it would help?

A web service is an agent that sends/receives messages and not an agent
that has operations (at least that's my understanding from the WSA

Just thinking aloud here.

Received on Friday, 5 September 2003 14:11:33 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:33 UTC