RE: The attribute formerly known as "name"

Thanks for pulling this together, Amy.

I think (as mentioned on the call) that any use of "role" is inappropriate for naming messages in patterns, since there is already a concept of "role" which encompasses the parties involved in the pattern as opposed to the messages.  "messageRole" is a little more descriptive than "role", but still potentially confusing I think.

"messageName" seems good to me, since that's what it is - the name of the message in the pattern spec.  "messageReference" (or "messageRef") would be good as well, since it makes it clear that this is a reference to an external document.


> -----Original Message-----
> From: Amelia A. Lewis [] 
> Sent: Thursday, September 04, 2003 12:19 PM
> To: WS Description List
> Subject: The attribute formerly known as "name"
> Dear folks,
> As promised, here is a list of suggestions to rename the 
> attribute "name", when it appears on the elements "input", 
> "output", and "fault". 
> This list of proposed replacements is in accord with issue 
> 77, which suggested that this instance of the usage of "name" 
> as an attribute was not consistent with other usages 
> throughout the specification.
> Several proposals for replacement were made on the 4 
> September teleconference.  Please respond to this email using 
> preference voting, indicating your top three preferences 
> (number them 1, 2, and 3, please).  I'll try to tabulate 
> responses that I receive (either publicly or
> off-list) immediately before the teleconference next week.  
> Note that you are free to propose an alternative not listed 
> here as well.
> role
> messageRole
> messageType
> messageName
> messageReference
> message
> reference
> identifier
> Amy!
> (that's my name, not a proposal ...)
> -- 
> Amelia A. Lewis
> Architect, TIBCO/Extensibility, Inc.

Received on Friday, 5 September 2003 13:16:59 UTC