Re: Add Subject Here

On Fri, Sep 26, 2008 at 6:04 PM, Bryan A Boone <> wrote:
> Hello everyone, I am trying to install the w3c html validator on my own
> internal server. I have it setup on FC9, running apache 2.2.9. I ran the
> installation for the W3C validator from the repository supplied in FC. The
> web page comes up just fine and seems to work great. However when I try to
> check a web page, upload a file, or do direct input in and hit check. I get
> an error.
> 404 Not found. The requested URL /check was not found on this server.
> I looked in the directory and indeed I do not see a "check" directory. the
> only think that is labeled check is in the cgi-bin folder and that is the
> check script.
> I looked on the w3c website for more problem like mine, and I came across
> the one about the referrer not being passed. I don't think this is the issue
> in my case. I am not going through any servers that are running firewalls or
> proxy software. I am simply have 2 web servers and a PC hooked up to a
> switch. I navigate to the web server that is hosting my w3c validator. I
> then point via IP address to the other web server that is running a very
> basic website. And I get the problem.
> I have turned on the option to allow private IP's.
> Also, I have tried to input the website to check directly. Like
> And that doesn't work either.
> If I go into a console and run the command
> ./check uri=
> this works.  I do indeed get HTML output and I see that it did indeed check
> the page for errors.
> Can anyone help?

I have no clue how Fedora expects you to install these, but it sounds
like you're missing the configuration for Apache.

See this file:

Read the comments and other info... you'll have to make modifications
for your environment.

Hope that helps!

Brett Bieber

Received on Sunday, 28 September 2008 23:34:16 UTC