W3C home > Mailing lists > Public > www-validator@w3.org > September 2008

Add Subject Here

From: Bryan A Boone <bbryan@us.ibm.com>
Date: Fri, 26 Sep 2008 16:04:28 -0700
To: www-validator@w3.org
Message-ID: <OFEB424CC1.51FD6928-ON872574D0.007C0157-072574D0.007EBFAB@us.ibm.com>

Hello everyone, I am trying to install the w3c html validator on my own
internal server.  I have it setup on FC9, running apache 2.2.9.  I ran the
installation for the W3C validator from the repository supplied in FC.  The
web page comes up just fine and seems to work great.  However when I try to
check a web page, upload a file, or do direct input in and hit check.  I
get an error.

404 Not found.  The requested URL /check was not found on this server.

I looked in the directory and indeed I do not see a "check" directory.  the
only think that is labeled check is in the cgi-bin folder and that is the
check script.

I looked on the w3c website for more problem like mine, and I came across
the one about the referrer not being passed.  I don't think this is the
issue in my case.  I am not going through any servers that are running
firewalls or proxy software.  I am simply have 2 web servers and a PC
hooked up to a switch.  I navigate to the web server that is hosting my w3c
validator.  I then point via IP address to the other web server that is
running a very basic website.  And I get the problem.

I have turned on the option to allow private IP's.

Also, I have tried to input the website to check directly.  Like

And that doesn't work either.

If I go into a console and run the command

../check uri=

this works.  I do indeed get HTML output and I see that it did indeed check
the page for errors.

Can anyone help?
Received on Sunday, 28 September 2008 20:34:41 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:59:09 UTC