Re: [css-containment] Splitting the "sizing" part from "layout" containment

Hehe yeah, that's fine. I think what I'm driving at is that both "strict"
and -- fair enough -- "all" both imply that 4/4 are accounted for. I wonder
if we need to use a different keyword for 3/4 (which I'm struggling to
think of!), but if we have either keyword it should mean 4/4.

Overall that might make the main case more verbose, but I'd prefer that
over saying "strict is kinda strict, except it doesn't mean this last one,
which is size. That's something you need to specify separately, so it's
only sort-of strict."

On Fri, Mar 18, 2016 at 5:40 PM Tab Atkins Jr. <> wrote:

> On Fri, Mar 18, 2016 at 6:39 AM, Paul Lewis <> wrote:
> > I think it's good to keep it as a single property, I just wonder if the
> term
> > "strict" implies that it should include "size" as well as the other
> three.
> > Not that I can think of a better keyword, but it's not strict if the
> size is
> > implicit. It feels like "all" might be a softer way to imply "layout",
> > "paint", and "style", with perhaps "strict" meaning all four. Either way
> I
> > can make it work, it just didn't feel like "strict" meant "strict" if it
> > only meant 3/4.
> Having "all" imply 3 of the 4, not all of them, seems immensely more
> confusing to me. ^_^
> ~TJ

Received on Friday, 18 March 2016 17:47:24 UTC