Re: [css-snap-size] Use 'factor' as the term?

On Thu, Mar 3, 2016 at 8:32 AM, Francois Remy <
> wrote:

> >
> > I like "step" quite a bit - it's also used by HTML in the <input
> type=number
> > step> attribute to mean exactly what we want here.
> I have no strong opinion on the matter.
> Step is shorter, but I would be fine with both.
I'm fine with all candidates, but likes "step" the most familiar.

For the object:

On Thu, Mar 3, 2016 at 6:30 AM, Alan Stearns <> wrote:

> The draft currently lets you do this for line box heights and available
> inline size. But the properties refer to ‘height’ and ‘width’ so it’s not
> very clear that it’s not the element’s height and width being modified. So
> instead of ‘snap-height’ I suggest the property be named
> ‘line-height-factor’.

"line-height-step" (or other if we end up so) works good for me. Thank you
for the suggestion again.

Then (and I’m less sure about this) your current ‘snap-width’ could change
> to ‘line-width-factor’. Again, this makes it more clear that what you’re
> setting affects available inline sizing. In this case there isn’t a
> property that directly sets available inline size, but one could be added
> as a shorthand for that and ‘line-width-factor’ in the future if it’s
> needed.

The available inline size is not only about "line"-width. It affects all
boxes in the container including line box and normal flow block box.

"inline-size-step" probably? That matches to your suggestion when we have
the "inline-size" property[1].



Received on Thursday, 3 March 2016 02:05:51 UTC